Back to overview
Downtime
All Sites are down
Dec 2, 2023 at 4:07pm UTC
Affected services
kieranbot.info
Resolved
Dec 2, 2023 at 4:11pm UTC
All services restored
Affected services
Created
Dec 2, 2023 at 4:07pm UTC
Due to an automated billing error from host provider all sites are down, we are working on getting them back up and running swiftly
Affected services